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What is BPPW (Overview)

The program, BPPW, tracks your Blood Pressure.    Systolic, Diastolic and Pulse readings for any date and time of 
day that is entered to a data base, and then stored in a file.    These measurements are made by an instrument called a 
Sphygmomanometer.    Electronic instruments may be obtained from most drug and department stores.    The 
program can store up to 100 readings in each file and up to 10 files per person.

This program can display up to 20 readings in a Line Graph  ,   plotting Systolic, Diastolic and Pulse, each in a 
different color, against the day of the month.    The graph is sizable, by dragging the windows border handles with 
the mouse, or by clicking the Min or Max buttons of the window.    The graph may be printed on a Line Printer or 
sent to Windows Clipboard or a BMP File to export data to another program.

Also See: BPPW History, New to This Version,and Disclaimer & Credits.



BPPW History (Overview)

Program Version Date Description
BP 1.00 3/27/90 DOS version, CGA - 2 color, QB 4.5
BP11 1.10 5/15/90 Fixes for version 1.00, QB 4.5
BPWIN 1.0w 10/15/92 First Windows version, VB 1.0
BPWIN 1.1w not released Fixes for Version 1.0w, VB 1.0
BPWIN 1.2w 4/24/93 Fixes for Version 1.0w & 1.1w, VB 2.0.    

Has opening error.
BPPW 2.0w 5/12/93 New version, VB 2.0.    Has opening error
BPPW 2.1w & 2.2w not released Fixes for version 2.0, VB 2.0
BPPW 2.3r This Version for Register users, VB 3.0
BPPW 2.3s This Version for Shareware users, VB 3.0

NOTE: QB means that the program was compiled by Microsoft's Quick Basic.
          VB means that the program was compiled by Microsoft's Visual Basic

Also See:    What is BPPW, New to this Version, and Disclaimer & Credits



New to this Version (Overview)

1. No more false Errors when program starts caused by a bad copy of Visual Basic 2.0.
2. All new 3D Forms.    Not simulated as in versions 1.x.
3. Now for the first time you can enter "Time-of-Readings" into the data base.
4. All data files for this version are compatible with earlier versions of this program.
5. Easy mouse entry of data using special Spin Controls.
6. Mouse entry controls are closer to each other so there is less mouse movement.
7. Alternate Keyboard entry using the new Masked Input Control.
8. You can not enter incorrect data.
9. Easier Editing.    You can now Modify, Delete and/or Insert data into the data base.
10. Large easy to see Data Table.    Now holds up the 20 records at a time.
11. Improved Graph display.    Size of graph is now adjustable, up to full screen.
12. Easy to print.    Can now print the graph directly to the line printer.
13. Easy to export graph to other programs, by via the Clipboard or a BMP file.
14. Real Microsoft's Windows Help File with Context Sensitive Help using F1.
15. Easy SETUP using Microsoft's setup engine.

Also See: What is BPPW, BPPW History and Disclaimer & Credits



Disclaimer & Credits (Overview)

Limited Warranty

THIS PROGRAM AND THE ACCOMPANYING DOCUMENTATION IS PROVIDED "AS IS" WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTIES OF MERCHANTABLITY AND FITNESS FOR A PARTICULAR PURPOSE WITH 
RESPECT TO DEFECTS IN THE PROGRAM OR DOCUMENTATION.    THE AUTHOR: RICHARD S. COHEN 
ASSUMES NO RISK TO THE QUALITY AND PERFORMANCE OF THIS PROGRAM.    SHOULD THE 
PROGRAM PROVE DEFECTIVE, YOU ASSUME THE ENTIRE COST OF ANY LOSS OF PROFIT OR ANY 
OTHER COMMERCIAL DAMAGE.

Credits

BP, BPWIN & BPPW are registered trademarks of Richard S. Cohen
Microsoft(R) Windows(TM) is a registered trademark of Microsoft Corporation
Visual Basic(R) vers 3.0 is a registered trademark of Microsoft Corporation
GRAPH.VBX & GSWDLL.DLL are registered trademarks of Pinnacle Publishing
SPIN.VBX is a registered trademark of OutRider Systems, Inc.
PKUNZIP(R) is a registered trademark of PKWARE, Inc.

Also See: What is BPPW, BPPW History, and New to this Version



File Menu

Command Hot Key Short Cut Action
New ALT+F, N (none) Create a NEW BP data file using BP for 

Dialog,and Common Files Dialog box .    
Also see Create a NEW DataBase.

Open ALT+F,O CTRL+F12 Open an existing BP data file using the 
Common Files Dialog box.    Also see Open 
an Existing Data Base.

Save ALT+F,S SHFT+F12 Save BP data to an existing data file.    Also 
see Save Data Base to a File

Save As ALT+F,A F12 Save BP data to an unknown data file using 
the "Common Files Save As" dialog box.    
Also see Save Data Base to a File

Print Data List ALT+F,P CTRL+P Print the BP Data List to the line printer.    Also
see Print a Data List.

(Active Data Files) ALT+F,# (none) Active Data Files that are found in the Data 
Path will be listed in a numbered list, between
the "Print Data List" and "Exit" in the File 
Menu.    This is a faster way of opening data 
file than using Open.    Also see Open an 
Existing Data Base

Exit ALT+F,X CTRL+F4 Exits the program.    

NOTE:    If there is any data that needs saving before the File Menu selection of New, Open, or Exit, a dialog box 
will open, requesting that the file should be saved.    Answer with Yes, will save the file and then continue with the 
selected command.    Answer No, will not save the file and then continue with the selected command.    In this case 
data not saved will be lost.    Answer with the Cancel Button will cancel the command and the file will not be saved.



Edit Menu

Command Hot Key Short Cut Action
Copy ALT+E,C CTRL+C Copy data from the Data Table to the Clipboard 

for exporting data to another program.    Also see 
How to Export Data.

Modify ALT+E,M CTRL+M Select record from Data Table for Modification.    
Also see How to Modify a Record.

Delete ALT+E,D CTRL+D Delete selected record from the Data Table.    Also
see How to Delete a Record

Insert ALT+E,I CTRL+I Inserts a record in the Data Table.    Also see How
to Insert a Record

Mouse Entry ALT+E,O CTRL+O Allow data entry using the Mouse (default).    
Also see Entering Data using the Mouse

Keyboard Entry ALT+E,K CTRL+K Allow data entry using the Keyboard.    Also see 
Entering Data using the Keyboard

Also See: Select a Record from the Data Table with the Mouse
Select a Record from the Data Table with the Keyboard



View & Graph Menus

From the "Blood Pressure Entry" window, select View from the File menu.    Hot Key is ALT+V,G and the Short Cut
Key is CTRL+G.    This will open the "Blood Pressure Graph" Window.

To display the graph, Click the Graph Area, or use the Space Bar on the keyboard.
How to Display a BP Graph

There is only one item in the Graph Window menu bar for the Action Menu



Forms Menu

From the "Blood Pressure Entry" window, select from the Forms menu, "Run BP Forms".    The Hot Key is 
ALT+M,R and the Short Cut Key is CTRL+F.    This will run an external program "BPForms".

See:    How to Use BP Forms



Action Menu

When in the Graph Window, Select the Action Menu, then...
Commands Hot Key Short Cut Action
Print Graph CTRL+A,P Open another menu, see the Print Graph menu 

below.
Exit graph CTRL+X Exits the Graph Window.

In the Print Graph Menu, select...
Commands Hot Key Short Cut Action
To Printer CTRL+A,P,P Sends Graph directly to the Line Printer
To Clipboard CTRL+A,P,C Sends Graph to the Clipboard.    See How to 

Export a BP Graph
To File CTRL+A,P,F Sends Graph to a BMP File.    See How to 

Export a BP Graph



Main Panel Controls

The Main Panel, located upper left corner of the "Blood Pressure Entry" window, consists of the program title with 
both the BPPW (Heart) and "Entry Window's" Icons.    

Below this is a 3D panel showing the active Data File Name.    If there is no active file, then the panel will display 
"No Data File Name".

Below this is another 3D panel showing "Records: ### of ###".    The First ### is the Record Count in Entry mode
and the Selected Record in Edit mode.    The second ### is the Last Record in the Data Base.

In Entry Mode, the first number will be the same as the last number, if there were no backups and the Last Record 
has not reached 100.    After a backup, the first number starts over again at one, and the second number stays at 100.

In Edit Mode, the first number will be the record selected, and the second number shows the Last Record or 100 if 
100 records were recorded.



Data Entry Area

Control Action
Daily Readings Click Check Box, or press ALT+Y.    See Note #1 below
Field Buttons The button that's ON, shows the active field.    See Note #2 below
Field Data Displays Display data for the field.    See Note #2 below
Mouse Entry or 
Keyboard Entry Area

Is a Changeable Control for different types on entry.    Mouse Entry 
Controls, or Keyboard Entry Controls

Enter .... Command 
Bar

Enter data into the field display, and into the Data Table after the last 
field is entered.    See Note #3.

Note #1:    When the Daily Readings Check Box (a Standard Window Control ) is checked, the Daily Readings 
box will display "YES".    Every time the program cycles through to the "Time-of-Readings" field the date will be 
updated to the next day.    With this feature, the operator doesn't have to change the date if he is entering data on 
daily bases.

Note #2:    There is 3 Fields with matching data displays.
Field Field Name Displays
#1 Date-of-Reading 2 digit day-3 letter month-2 digit day.          Example: 10-Jul-93
#2 Time-of-Reading 2 digit hour: 2 digit minutes AM/PM            Example: 08: 30 AM
#3 BP & Pulse BP: ###/## Pulse: ###                                                              Example: BP: 130/80

Pulse: 65

Note #3:    The caption on the Enter... bar changes when the field changes.
Field Enter... Bar Caption
#1 Enter Date-of-Reading
#2 Enter Time-of-Reading
#3 Enter BP & Pulse

Also See: Custom Controls



Mouse or Keyboard Entry Area

Mouse Entry Controls
Keyboard Entry Contols

Also see: Data Entry Area



Data Table Area

This area contains only one Custom Controls, the Grid.    The Data Table displays up to 20 records or BP readings. 
in 20 rows.    There are 4 columns for:    Date, Time, BP, and Pulse.    If there are more than 20 records in the data 
base, the Data Table will automatically add a vertical scroll bar so you may scroll through all records.



BP Graph Area

The BP Graph, found in the "Blood Pressure Graph" Window, is one of the Custom Controls.    The graph displays 
a 3 Line Graph, one for Systolic, one for Diastolic and one for Pulse.    All plotted against the Day of Entry.    The 
graph actually plots what is in the Data Table.    If there are 20 items in the Data Table, there will be 20 readings 
plotted on the graph.    There must be at least 4 readings in the Data Base

Also See:
How to Display a BP Graph
How to Print a BP Graph
How to Export a BP Graph



File Management

The following File Management Procedures may be performed.

Create a NEW Data Base
OPEN an Existing Data Base
SAVE Data Base to a File
PRINT a Data List

Also see: Data Entry
Editing Data Records
Printing & Exporting Data



Data Entry

The following Data Entry procedures may be performed.

Entering Data Using the Mouse
Entering Data Using the Keyboard

Also see: File Management
Editing Data Records
Printing & Exporting Data



Editing Data Records

The following Editing procedures may be performed.

How to Modify a Record
How to Delete a Record
How to Insert a Record

Also see: File Managment
Data Entry
Printing & Exporting Data



Printing & Exporting Data

Displaying How to Display a BP Graph

Printing: Print a Data List
How to Print a BP Graph

Exporting How to Export Data
How to Export a BP Graph

Also see: File Managment
Data Entry
Editing Data Records



Entering Data using the Mouse

Start with program running with the Blood Pressure Entry Window Opened.
1. If the "Keyboard Entry" area is active, Select the Edit menu and note that Keyboard Entry item is Checked.    

Select the "Mouse Entry" item from this menu to activate the "Mouse Entry" area.
2. If you are entering data for each day, you will want the "Daily Readings" to be checked On (Yes).    This way 

the date will be incremented each time you enters the "Date-of-Reading" field.    Other wise, "Daily Readings"
should be unchecked (Off).

3. Tab (move) to the first field, Date-of-Readings so that it's option button is On.
4. If the date in the field window is not correct, use the three Spin buttons to increase or decrease the Day, Month

or Year.    
5. When the Date values are correct, select the "Enter Date-of-Reading" command button.    The next field, Time-

of-Reading option button will be On.
6. If the time in the field window is not correct, use the two Spin buttons to increase or decrease the Hour or 

Minute.    If the AM or PM part of the time is incorrect, hold the Spin button down until the time is either AM 
or PM.

7. When the Time values are correct, select the "Enter Time-of Reading" command button.    The next field, "BP 
& Pulse" option button will be On.

8. If any of values in the BP & Pulse are not correct, use the three Spin buttons to increase or decrease the 
Systolic, Diastolic or Pulse.

9. When the BP and Pulse are correct, Select the "Enter BP & Pulse" command button.    The data will be 
transferred from the Field windows to the Data Table.    The record Count will be updated and the first field, 
Date-of-Reading, option button will be activated.

10. Repeat steps 4 to 9 until done.



Entering Data using the Keyboard

Start with program running with the Blood Pressure Entry Window Opened.
1. If the "Mouse Entry" area is active.    Select the Edit menu and note that Mouse Entry item is Checked.    

Select the "Keyboard Entry" item from this menu to activate the "Keyboard Entry" area.
2. Inside the Keyboard Entry area, will be a special entry box (Masked Input Control).
3. With the first field, Date-of-Reading, option button selected, the field data box will show the default date.
4. To Change the Date..

Press the "+" key on the number keypad to increment the day.
Press the "-" key on the number keypad to decrement the day
    or just highlight and type in a new date.    For example, type: 04jan93    for    04-Jan-93.

5. When the date is correct, press the Tab key and then the Space-Bar (or Enter key).    This will make the Time-
of-Reading option button active.

6. If the time needs changing, type a new time.    For example, type: 0730am    for    07:30 AM
7. When the time is correct, press the Tab key and then the Space-Bar (or Enter key).    This will make the BP 

and Pulse option button active.
8. If any BP or Pulse values need changing, type in the new values, for example:    type: 1307868    for    BP: 

130/78 Pulse 68.
9. When correct, press the Tab key and then the Space-Bar (or Enter key).    Data will be transferred from the 

field boxes to the "Data Table".    The first field, Date-of-Reading option button will be On.
10. Repeat steps 4 to 9 until done.



Select a Record from the Data Table with the Mouse

To select a record from the Data Table using the Mouse.
1. Locate the data record required in the Data Table.
2. Click any Column in the Row of the wanted record.
3. All columns in that row, except for the one that was clicked on, become highlighted.
4. The first ### in the "Record: ### of ###" display will be the selected record

All data for that record in the Data Table will be displayed in the Field Data boxes.
In the File menu, Modify will be checked.

5. Now ready to Modify, Delete or Insert.
6. Deselect the Data Table by clicking on the Data Table header.



Select a Record from the Data Table with the Keyboard

To select a record from the Data Table using the Keyboard.
1. From the File menu, select Modify.
2. The Edit dialog box opens with the message: "Need to Select a Record to Modify".    Select the Ok button.
3. Use the "+" key to increment Records (move highlight down), or

Use the "-" key to decrement Records (move highlight up)
Use "ESC" key to cancel operation.

4. When the correct record is selected, the first ### in the "Record: ### of ###" display will be the selected 
record.    All data for that record in the Data Table will be displayed in Field Data boxes.

5. Now ready to Modify, Delete or Insert.
6. Cancel selection with the Edit menu.    Note that Modify is checked, select Modify command.



How to Modify a Record

To change one or more fields of a record that is already stored in the Data Table.
1. Select the row in the Data Table which contains the record you wish to modify.

Select a Record from the Data Table with the Mouse
Select a Record from the Data Table with the Keyboard

2. Re-enter the data for each field that needs changing.
Entering Data using the Mouse.
Entering Data using the Keyboard.

3. With all data fields corrected, and the BP & Pulse option button On, select the "Enter BP & Pulse" command 
bar.    All data will be transferred from the data field boxes the highlighted row in the Data Table.

4. Repeat steps 1 to 3 above, until all editing is complete.
5. When done, cancel the Modify command.

1. With the Mouse, click any column of the Data Table Heading.    For example, Click the word "Date" 
in the heading.
2. Or, select from the Edit menu, the checked item "Modify".

6. Note:    All the above changes are made only to the Data Table.    The data still must be saved to the file on disk 
to become permanent.



How to Delete a Record

To delete a record from the Data Table.
1. Select the row in the Data Table which contains the record you wish to delete.

Select a Record from the Data Table with the Mouse
Select a Record from the Data Table with the Keyboard

2. From the Edit menu, select Delete.
3. The selected row in the Data Table will disappear and all preceding records will move up to fill the space.
4. Repeat steps 1 to 3 above to delete other records.
5. Note:    All deletions made here is done only to the Data Table.    The data must be saved to the file on disk to 

become permanent.



How to Insert a Record

To insert a new record between two existing records in the Data Table.
1. Select the row in the Data Table that contains the insertion point.    The point where the new record will be 

inserted.
Select a Record from the Data Table with the Mouse
Select a Record from the Data Table with the Keyboard

2. From the Edit menu, select Insert.
3. All data will be push down from the insertion point to the last record.    There will be two identical records at 

the select row and the one below it.
4. Change the data in the selected row to the new data as in

How to Modify a Record.
5. Repeat steps 1 to 4 until done.
6. Note:    All changes are completed only to the Data Table.    The data must be saved to the file on disk to 

become permanent.



How to Export Data

Data may be exported from the Data Table to another program (such as Windows WRITE.EXE) via the Clipboard.    
Only data currently displayed in the Data Table will be exported.
1. With the program running, and a data file is opened, scroll the data in the data table to display the data you wish

to export.
2. Select from the File menu, Copy.
3. You may have the Clipboard Viewer opened to see the data in the clipboard.
4. Open the destination program, if not already opened, with it's data file opened.
5. Move the cursor to the Insertion Point, where you want the BP data to go.
6. Select from the destination program's Edit menu, the paste command.
7. Repeat steps 1 to 6 until done.    Note:    The clipboard will only accept one set of data at a time.
8. You may have to Format the data in the Destination Program before using it.    Data items in the clipboard will 

be separated by a tab character and the end of each row of data contains a carriage return.



Create a NEW Data Base

Start with program running with the Blood Pressure Entry Window Opened.
1. Select NEW, from the File Menu.    The "New User" dialog box opens.
2. Enter a name in the "Who is BP Readings For" box.    Select OK button.
3. The Common Files Dialog (Save As) opens.
4. Use:    Save File as Type: "BP Data (*.BPW).
5. Enter a unique Data File Name in the File Name box.    Select OK button
6. Now ready to add NEW data to the data base.



OPEN an Existing Data Base

There are two ways to open an existing data file.    First, using the Common File Dialog box, we can open files that 
is in different sub directories.    You should use this method to open backup files.
1. From the File menu, select Open.
2. If there is data in the Data Table that was not saved, the operator will now be prompt to do so.

If operator answers the dialog with "YES", the existing file will be saved, then continue to item 3.
If operator answers the dialog with "NO"    the existing file is not saved, then continue to item 3
If operator answers the dialog with "Cancel", the file is not saved, and exits Open function.

3. The Common File Dialog (Open) box opens.    Select Drive, Path, File Type, File Name as required.
For example:    Click File Name, then OK button, or
Double-Click on File Name.

4. Data file, that was selected loads and data is displayed in the Data Table.

Another way to open an existing data file, is much faster.    When the program, BPPW, first loads it looks into the 
Data Path for existing data files, then lists these file names in the File Menu.
1. Select the File Menu.    You should see a list of numbered file names between the "Print Data List" and "Exit" 

menu items.    If there is only one dimmed listing such as "1. No Data File", there are no files to open.    See:    
Create a New Data File

2. If there is a numbered list, select the file name to load or type the underlined number for that file.
3. Data file, that was selected loads and data is displayed in the Data Table.



Save Data Base to a File

After Entering data to the Data Table, or if any data in the Data Table needed Editing, The Data Table (Data Base) 
needs to be saved to a file, or all data will be lost.
1. If the Data File name is known, for example, it was previously Opened.    All was needed is to select Save 

from the File Menu.
2. If the Data File name is not known, for example, data was entered fresh after the program started, or you wish 

to save the data file under a new file name, then ....
3. Open the File menu and select "Save As".    The Common File Dialog (Save As) box opens.    Enter a unique 

file name in the File Name box and select the OK button.



PRINT a Data List

To Print a complete list of the Data Base, that is every thing in the Data Table.    Select from the File menu, Print 
Data List.



How to Display a BP Graph

1. With the program running with an opened data file, scroll the Data Table until the data you wish to plot is 
visible.

2. Select from the View menu, the Graph, to open the "Blood Pressure Graph" window.
3. The graph window opens.    If there is enough data for plotting, Click the graph display with the mouse, or use 

the keyboard's Space-Bar.    The Graph is displayed.



How to Print a BP Graph

1. Display the Graph.    See:    How to Display a BP Graph.
2. Select from the Action menu, the Print Graph command.
3. The Print Graph menu opens, select the To Printer command.
4. The graph as shown on the screen will print to the line printer.



How to Export a BP Graph

There are two different ways to export a BP Graph.

By way of the Clipboard, export to another program like WRITE.EXE.
1. Display the Graph.    See:    How to Display a BP Graph.
2. Select from the Action menu, the Print Graph command.
3. The Print Graph menu opens, select the To Clipboard command.
4. The graph as shown on the screen will be copied to the Clipboard.
5. You may view the contents of the clipboard in the Clipboard Viewer.
6. Open the destination program, if not already opened, with a running data file.
7. In the destination program, move the cursor to the Insertion Point, and select from the Edit menu, Paste.
8. Repeat steps 1 to 7 until all data is transported.    Note:    The clipboard can hold only one graph at a time.

By way of a BMP File, export to another program like PAINT.EXE.
1. Display the Graph.    See:    How to Display a BP Graph.
2. Select from the Action menu, the Print Graph command.
3. The Print Graph menu opens, select the To File command.
4. You will prompt for a BMP File name.
5. The graph as shown on the screen will be copied to that file.
6. Open the Paint Brush program, if not already opened.
7. Move the cursor to the Insertion Point, and select from the Edit menu, Paste.
8. Repeat steps 1 to 7 until all data is transported.



How to Use BP Forms

BP Forms is an external program which will print out to your line printer a Blank or Dated Form.    This form may 
be used to write in BP data, while taking your blood pressure, before entering them in to the computer.

1. Open BP Forms, from the BPPW program, by selecting from the Forms menu, Run BP Forms.    See:    Forms 
Menu.    The Forms program may also be run from Windows Program Manager or File Manager.    The "Blood 
Pressure Plotter - Forms" window will open.

2. Enter the persons name in the field, Blood Pressure is for, and press the Tab key.
3. Enter the file name in the field, File Name used, and press the Tab key.
4. Select the Step Date option button:

None Prints form with no dates.
Daily Prints form with dates.    Every day of the month, one month per page.
Weekly Prints form with dates.    One date per week.
Monthly Prints form with dates.    One date per month, one year per page.

Press Tab key
5. Change Start Date on field, if necessary, to the first date you want printed on the form.    Date format is DD-

MMM-YY, for example:    01-Jan-93.
6. Change Number of Copies field, if necessary.    If Step Date is set to Daily, each new copy will be the next 

month from the Start Date.
7. Make sure the Printer is ON, and ON Line.    Select the Start Print command button.

Tips:    I use the Daily Step Date all the time.    If I miss a date, I just X it out.    The form is printed with dates only 
on the left side.    The right side is used for extra readings, if there are more than one reading on a certain day.    
The right side may also be used for notes:    The next doctors visit, your weight readings, etc..    I also print out a 
form with the Step Date set to None in case I need extra space.



Getting Started

1. If you are new to this program, get use to it by using the Sample data, before using your own data.
2. Create your entry forms.    See:    How to use BP Forms.    Use these forms when you take your blood pressure

readings.
3. Create your Data File.    See:    Create a NEW Data Base.    
4. Enter data from the forms created in step 2, in to this program.    See:    Data Entry.    
5. When Data Entry is completed, then Save Data Base to a File.    



Standard Window Controls

Except for the 3D appearance most controls in this program are Standard Window Controls.    All menus, check 
boxes, options buttons and display boxes are standard.    For information on using these controls, see your 
Microsoft's Windows manual.    The common dialog box used to "Open" or "Save As" a file is standard, to Windows 
3.1, but a special VBX file is required for use in this program.



Custom Controls

This program uses several controls that can not be found in Microsoft's Windows manual.
Control Added Files Use
Mask Input MSMASKED.VB

X
Use for keyboard entry of    data.    Allow only certain characters 
to be entered.    Used for formatted input.

Spin SPIN.VBX A double action button to spin up or down values of input using 
the mouse

Grid GRID.VBX Use in the Data Table.
Graph GRAPH.VBX, 

GSWDLL.DLL 
GSW.EXE

Used to control and draw the line graph.



Changeable Controls

Some controls in this program change as the program runs.    For example, the Mouse Entry Area can change to the 
Keyboard Entry Area, and then back, with a menu selection.

The Spin Controls and their labels change when the program goes from one field to another,
also, the Enter (command button) changes captions.

Field Spin 1 Spin 2 Spin 3 Command Button Caption
Date-of Reading Day Month Year Enter Date-of-Reading
Time-of Reading Hour Minute (not used) Enter Time-of-Reading
BP & Pulse Systolic Diastolic Pulse Enter BP & Pulse

Mouse Entry Controls

With the Mouse Entry Area Active.    See Edit Menu

Up to three Spin Controls are visible.

See: Custom Controls and Changeable Controls.



Keyboard Entry Controls

With the Keyboard Entry Area Active.    See Edit Menu

The Masked Input Control becomes visible.
This is one of the Custom Controls and Changeable Controls.



Technical Information

BPPW Requirements
Data File Format
Information File Format
How Backup Works



BPPW Requirements

This program will run on any computer that will run Micosoft's Windows.    We recommend at least, a 386, 25 mhz 
IBM compatible, with 4 Meg. memory, VGA Color graphics controler and monitor, a mouse and printer.

A home blood pressure measuring device.    There are many fine electronic kits on the market that will measure 
Systolic, Diastolic pressure and Pulse.

This program was compliled by Microsoft's Visual Basic version 3.0, and requires several files supplied by them.    
VBRUN300.DLL will only be supplied in Registered versions.    Shareware users must down load this file from their
local Bulletin Board.    See the README.DOC File for a list of required files.



Data File Format

The Format for the Header: "Users Name",<Last Record#>,<Backup Number#>,<Record Count#>
The Format for the Data Record <Date#.Time#>,<Systolic#>,<Diastolic#>,<Pulse#>

1. A data file, Just NEWed, with Header and no data records.
Line 1: "John",0,0,0

This means that the file is for a person named "John", and Last Record is 0, there are no backups and Record 
Count is also 0.

2. The same data file above with one data record added.
Line 1: "John",1,0,1
Line 2: 33789,134,83,70

This means the data file for "John" has a Last Record of 1, no backups, and the Record Count of 1.
The first number, 33789, in line 2 is a date code for "Date-of-Reading", Systolic reading is 134, Diastolic 
reading is 83 and the Pulse is 70.

3. The same data file above with 100 records.
Line 1: "John",100,0,100
Line 2: 33789,134,83,70
Line 3: 33790,138,78,65
 (etc)...............
Line 101: 33889.12345,146,85,68

Now the file for "John" has 100 records in the Last Record and the Record Count.    Still no backups
Line 2 is the same.
Line 3 has the same format for the next day, blood pressure is 138/78 and pulse is 65.
Line 101, the last line, shows a real number (with a decimal point) for the first number.    Left of the decimal 
point is for the "Date-of-Reading" and right of the decimal point is for the "Time-of-Reading".    The BP is 
146/85 and Pulse is 68.

4. The same data file with one record added to the 100 record data file of above.
Line 1: "John",100,1,1
Line 2: 33790, 138,78,65
(etc)................
Line 100: 33889.12345, 146,85,68
Line 101: 33890.12345,138,79,65

The File for "John" still has 100 for the Last Record.    One backup file, JOHN.BU1, was created, and the 
Record Count was restarted back at one.    All records are moved up by one.    The original line 2 moved up to 
line 1.    Line 1 would be lost, if it wasn't saved in the backup.    Line 101 moved to line 100 and new data was 
moved to line 101.



Information File Format

The Information File has the following Format:
Value for Item What it Does
"2.23" Version of Information File
"Shareware" Registered to...
"0000" Program ID number
"00000-0000 Serial number
"C:\BPPW2" Program Path
"C:\BPPW2\DATA" Data Path
"MSWRITE_MENU
"

used by version 1

"WRITE.EXE" used by version 1
"True" Sets the Use Daily check box

Note: The values for your items may be different than above.



How Backup Works

The BPPW data base and data files can hold a maximum of 100 records.    After entering the 100th record, you will 
be prompted for backup, after which, by adding more records will cause all data to move up, making room for a new
record at the bottom, and loosing the record at the top.

If you answered YES to the backup prompt, the data base will be saved to a backup file with the BU# extension.    
The # will start with the number one, for example SAMPLE.BU1.    After another 100 records and another backup, 
the # will be incremented, so the second backup file will be SAMPLE.BU2.    This can continue until BU9, after 
which, the next backup is BU1 and overwrites your first backup.



Shareware Version (BPPW23s)

The shareware version of this program, version 2.3s, opens and closes the program with a special "Shareware 
Registration Notice" dialog box.    Please read all the information in this dialog.    There are four command buttons 
on this dialog, that allows you to continue, cancel, prepare a Registration letter, and to enter information into your 
program after you registered your copy of this program.

If you don't register:    (apply only to version 2.3s)
1. You must remove this program from your system after the 30 day trial period.
2. You will continue to see the "Shareware Registration Notice" every time this programs starts and ends.    After

registration, this Notice will no longer appear.
3. You will not receive any support, and future notice of upgrades.    After registration, you will receive notice of 

upgrades and will receive your first upgrade FREE, except for a small fee for postage and handling.    You can 
also receive support with any problems you may have using this program.

Conditions of using this program before registering:
1. Use BPPW for up to 30 days, free, for evaluation.    After 30 days, either register or remove the program.
2. You may make copies for your friends and for uploading to Bulletin Boards, under these conditions:

1. All files included with this program must be included.
2. There are no changes or modifications to any of the files.
3. You can not charge a fee for this program, except for the cost of the medium it is on.
4. The registered version of this program, version 2.3r, must not be shared by anyone, and used only by the 
person who registered that copy

How to register:
1. With the "Shareware Registration Notice" dialog opened, select the Send Register Lettercommand button.
2. After you fill out this form, on your computer correctly, mail this form with a check, money order, or cash in 

US dollars made out to Richard S. Cohen.
3. You will receive, from us, a letter with information on how to remove the registration notice from your 

program.
4. Run the program again, with the "Shareware Registration Notice" dialog opened, select the Registration 

Informationcommand button, and enter the information from the letter.



Send Register Letter Dialog

1. This dialog opens when the "Send Register Letter" command button is selected from the "Shareware 
Registration Notice" dialog.    See Shareware Version

2. Fill in the form correctly.    To be able to print the letter, you must enter information in the Name, Street 
Address, City, State and Zip.    If you live in the USA, skip step 3.

3. For Foreign registers, note that the fields for State, Zip and Phone are formatted for the United States.
1. Fill out the Name, Street Address, and Address 2 as you normally would.
2. In the City field, enter your City and Country.
3. In the State field, enter XX if you can't enter a two letter abbreviation.
4. In the Zip field, you can enter zeros, for example 00000
5. The phone number is not required.
6. The Date of Registration is in the form of "Day-Month-Year", where Day is    "01 to 31", Month is "Jan to 
Dec" and year is "93 to 99", or use the default date.

4. If you enter a quantity greater than one, the program will calculate the Send Total field.    This amount is in 
US dollars.

5. We ask for the size of your floppy disk in Disk Size, if we need to send you an upgrade.    All disks are DSHD,
and are formatted 1.2 meg for 5.25 inch disks and 1.44 meg for 3.5 inch disks.

6. In the Pay By field, you can send the fee by...
1. Cash, not recommended.    Foreign registers can send cash, but, it's recommended to register your letter 
with your post office.
2. Personal Check made out to Richard S. Cohen, or money order.
3. I can not accept any Charge Account orders.

7. If you want the program to open with a default data file, enter the file name in the Default File Name field.
8. When all data is intered and is checked for correctness, you are ready to print.

1. Check to see if your printer is ON and ON-LINE.
2. Select the Print Letter command button.



Registration Information Dialog

1. When we receive your registration letter, we will send you letter on how to remove the Shareware Registration
Notice dialog from your program.

2. When you receive this letter, run the BPPW program.    When the Shareware Registration Notice dialog opens, 
select the Registration Information button.

3. When the Registration Information dialog opens, fill in the form from the letter.    Make sure that you enter the 
data correctly and exactly as printed in the letter.    The data fields to fill in are:    User's Name, Program ID 
number, and Serial Number.    Select the OK command button when done.

4. If the program accepts the data entered, exit the program and re-start BPPW for the changes to take effect.



Glossary (Definitions)
3D Forms
Backup
Blood Pressure
BMP File
BP for Dialog
BPPW
Changeable Controls
Clipboard
Common Files Dialog
Custom Controls
Data Base
Data Path
Data Table
Diastolic
Graph Control
Grid Control
Hot Key
Last Record
Line Graph
Masked Input Control
Pulse
Record Count
Selected Records
Shareware
Short Cut
Spheogmomanometer
Spin Controls
Standard Windows Control
Systolic



3D Forms
All forms in this program, except for dialog boxes, will have a 3d appearance.    All controls, panels, and displays 
will either be recessed or appear to stand-out.    This is different from the 3d forms of earlier versions of this 
program, in which the 3d effects were drawn on the screen.    Some times the program would miss a re-paint 
command and portions of the screen would lose its 3d and become flat.    In this version, the controls are actual 3d 
controls.



Backup
Making a copy of the data base and saving it in another file, other then the original file.    In this program, we are 
limited to 100 records in the data base.    We want to continue entering new records after the 100th record without 
starting a new data base.    BPPW gives you the option of saving the data base in 100 record chunks.



Blood Pressure
The pressure exerted by the blood against the inner walls of a blood vessel, usually an artery.    The pressure is 
created by the pumping action or contraction of the heart.    Doctors can determine when a person's health when this 
pressure is too high or too low.    High blood pressure can be very serious and may have a specific cause, such as 
hypertension.    Strokes, heart or kidney failure can occur if not discovered early.    It may be controlled by diet, 
therapy or medication.



BMP File
A BMP file is a picture file saved in a bit map format.    This file may be loaded into a drawing program like 
Window's Paint Brush.    BMP file may be used to transport your BPPW graph to another program.    You can also 
create a Window's Wall Paper of your graph.



BP For dialog
A dialog box that allows the operator to enter a name of a person the blood pressure readings is for.



BPPW
BPPW is the name of this program.    Stands for Blood Pressure Plotter for Windows.



Changeable Control
A control that does something else during different operations of the program.



Clipboard
Use the Window's Clipboard to transport data and/or graphs to another program.    Only one transfer is possible at a 
time.    Can be used with any program that has a Paste command in its Edit menu.



Common Files dialog
Standard to Windows 3.1, BPPW uses the same "Open" and "Save As" dialog box when called from the File Menu.   
Although it is standard, this program needs to add special files to use it.    See the file list



Custom Controls
A custom control is a control that you will not find in Microsoft's Windows Manual.    You will need this Help File to
use the Masked Input Control, the Grid Control, and the Graph Control that is used in this program.



Data Base
The data base is all records that are stored in memory, before or after a save to a disk file.    This program can have 
up to 100 records of data, plus a header record.



Data Path
The Data Path, or sub directory, is where data files are stored on disk.    It may be the same directory where the 
programs or stored.    It is recommended that a different directory to be used for backup.



Data Table
The Data Table is located on the left side of the "Blood Pressure Entry" window.    It can hold a complete data base, 
but only display 20 records at a time.    When there is more than 20 records, a scroll bar is provided.    Data in the 
Data Table may or may not be saved to a data file.    Data cannot be entered directly to the Data Table, but via the 
Data Field Boxes.    Selection of a record, for editing purposes, can be performed by clicking a cell in the Data Table 
with the mouse.    The Data Table uses a Grid Control, a custom control.



Diastolic
Diastolic is the minimum pressure exerted by the heart.



Graph Control
A custom control that displays three line graphs, Systolic, Diastolic and Pulse against the day of the month.



Grid Control
A custom control which is used by the Data Table.



Hot Key
When using the program with the keyboard instead of a mouse, you have to use the Hot Keys.    For selecting menu 
bar items and some controls in a window, use ALT+(underlined key).    For pull-down menus, press the underlined 
letter for selection.    See Microsoft's Windows manual for more information.



Last Record
The Last Record in the Data Base.    If only 50 records are entered, the last record is 50.    If over 100 records were 
entered, the last record will remain at 100 requardless of how many backups were made.    In the Entry window, the 
records displays:      Record ### of ###.      The last Record is the second ###.



Line Graph
This program display a line graph of Systolic, Diastolic and Pulse, plotted against the Day of the month.



Masked Input Control
A custom control that is used for Keyboard entry of data instead of the mouse.    This control allows only formatted 
input which is determined by which field is active.    For example, when "Date-of-Reading" field is active, you 
would enter 15jul93 for 15-Jul-93.    Numbers are allowed only where numbers go, and    letters allowed only where 
letters go.



Pulse
The rate in which the heart beats.    Most BP devices read the pulse, therefore can be saved to the data base.



Record Count
The Record Count keeps track of the number of records in the Data Base, even between backups.    When first 
started the Record Count, will step with each record entered, from 1 to 100.    On the next record, wheather a backup 
was made or not, the Record Count starts back at 1.    (The Last Record stays at 100.)    In the Record display,    
Records ### of ###.    The first ### is the Record Count



Selected Record
For editing purposes we must Select a Record to modify, delete or be the Insertion point for a Inserted record.    
When using a mouse, click the row where the record is located in the Data Table.    When using the keyboard, select 
Modify from the Edit menu, then use the Plus (+) and Minus (-) keys to move the selected item up or down the 
Data Table.    When selected (modified checked), In the Record display,    Records ### of ###.    The first ### display
the selected record.



Shareware
Shareware allows you to try out software before purchasing.    This eliminates the risk of purchasing software that 
may not meet your needs.    If you continue to use the program after a reasonable evaluation period, you need to 
Register with the author for a reasonable fee.



Short Cut
Use the Short Cut key to execute a command without using the menu.    The short cut code is displayed right of the 
command in the pull-down menu.    For example, in the File menu, Print Data List command is Ctrl+P.    By using 
the Ctrl+P Short Cut key combination, the program will execute the print command without using the menu.    See 
Microsoft's Windows Manual for more details.



Sphygmomanometer
An instrument that measure Blood Pressure.    Most electronic devices also measure the Pulse as well.    The device 
consists of an activate bag in a cuff, and inflation bulb and valve, all connected to the electronic unit.    This unit has 
an ON/OFF switch, an LCD to see the readings and is run by batteries.    A stethoscope, used by non-electronic 
devices is not necessary.



Spin Control
A custom control, used to increment or decrement data values in the field display boxes.    The control has an Up and
Down button built into it.    When you hold the mouse (this control only works with the mouse) pointer over the up-
button the values will spin up, the down-button spins down.



Standard Window Control
Standard Window Controls are controls that can be found in Microsoft's Windows manual.    See this manual for 
information on these controls.    The standard controls in this program, other than 3D appearance, are:    Menus, 
Check Box, Option Buttons, and Display boxes.



Systolic
Systolic is the maximum pressure exerted by the heart.






